葛廷彬的学习博客

记录学习工作中碰到的问题

中兴路由器连外网+华三核心交换机网络构架实验

网络设计:中兴路由器连外网+华三核心交换机
中兴4G路由器
配置G6 ip地址:172.16.12.119/24   //网络出口地址
配置G5 ip地址:192.168.0.1/29  //互联地址
G1-G4开DHCP: 192.168.10.1 //给任意pc使用


华三交换机:
网络地址:192.168.100.1/24 
接口ip地址:192.168.0.2/29  互联地址
静态路由:ip route 0.0.0.0 0.0.0.0 192.168.0.1
----------------------------------------------------中兴配置-----------------------------------------
1:中兴CRT链接
ssh==》serial
端口:以实际为准
波特率:115200
数据位:8
其他默认……
流控全部留空

2:中兴初始化:
ZXR10>en 18
Password:zxr10
ZXR10#startrun restore default

3:登录web
——OAM口——
https://192.168.1.1/
msr
zxr10msr


配置路由
ZXR10#con t  /进入配置模式
ZXR10(config)#ip route 192.168.1.0 255.255.255.0 192.168.0.2    //下联路由
ZXR10(config)#ip route 192.168.100.0 255.255.255.0 192.168.0.2  //下联路由

配置dns
ZXR10(config)#ip dhcp pool web_ds_vlan1  //增加dhcp配置的dns设置
ZXR10(config)#no import //import interface gei-2/6 dns删除之
ZXR10(config)#dns-server 202.102.152.3  //dns
ZXR10(config)#dns-server 202.102.128.8 //dns

配置接口gei-2/5到net上去
ZXR10(config)#cgn //net配置1
ZXR10(config-cgn)#show this  //查看当前
ZXR10(config-cgn)# subscriber ipv4 public subscriber-id 4000 nat-domain 4000  //net配置2
ZXR10(config-cgn-sub)#show this //查看当前
ZXR10(config-cgn-sub)#interface gei-2/5  //增加接口
ZXR10(config-cgn-sub)#exit   //退出
ZXR10#write  //保存配置
----------------------------------------------------华三配置--------------------------------------------------
华三-CRT链接:
ssh==》serial
端口:以实际为准
波特率:9600
数据位:8
其他默认……
流控全部留空

把交换机恢复出厂设置:
<H3C>reboot  //重启交换机
在交换机启动的过程出现提示按CTRL+B的时候按下CTRL+B,
进入BIOS界面
注意 需要按两下回车。
在这个视图下选择6进入重启不运行当前文件,
然后按"0"对交换机进行重启


创建配置接口ip:192.168.0.2
<H3C> sys  //进入权限
[H3C]vlan 100  //创建VLAN100
[H3C-vlan10]quit   //退出
[H3C]interface Vlan-interface 100    //进入vlan2进行配置//
[H3C-Vlan-interface100]ip address 192.168.0.2 255.255.255.248   //给VLAN2添加IP
[H3C-Vlan-interface100]quit   //退出
[H3C]interface e1/0/24
[H3C-GigabitEthernet1/0/24]port access vlan 100 //把2端口添加到VLAN2里面’

配置入网ip:192.168.100.1
[H3C]vlan 200  //创建VLAN200
[H3C-vlan10]quit   //退出
[H3C]interface Vlan-interface 200    //进入vlan200进行配置//
[H3C-Vlan-interface200]ip address 192.168.100.1 255.255.255.0   //给VLAN200添加IP
[H3C-Vlan-interface200]quit   //退出
[H3C]interface e1/0/1
[H3C-GigabitEthernet1/0/1]port access vlan 200 //把1端口添加到VLAN200里面
[H3C]interface e1/0/2
[H3C-GigabitEthernet1/0/2]port access vlan 200 //把2端口添加到VLAN200里面

配置入网ip:192.168.1.1
[H3C]vlan 300  //创建VLAN200
[H3C-vlan10]quit   //退出
[H3C]interface Vlan-interface 300    //进入vlan200进行配置//
[H3C-Vlan-interface200]ip address 192.168.1.1 255.255.255.0   //给VLAN300添加IP
[H3C-Vlan-interface200]quit   //退出
[H3C]interface e1/0/23
[H3C-GigabitEthernet1/0/23]port access vlan 300 //把1端口添加到VLAN300里面

 

创建默认路由
ip route 0.0.0.0 0.0.0.0 192.168.0.1

 

给vlan200配置dhcp
[H3C]dhcp enable                  //开启DHCP服务功能
[H3C]dhcp server ip-pool 200     //创建地址池
[H3C-dhcp-pool-200]network 192.168.100.0 24 /分配的ip地址网络
[H3C-dhcp-pool-200]gateway-list 192.168.100.1 //网关
[H3C-dhcp-pool-200]dns-list 202.102.152.3  //DNS服务器
[H3C-dhcp-pool-200]expired unlimited    //租约时间
[H3C-dhcp-pool-200]q              //退出
[H3C]dhcp server forbidden-ip 192.168.100.1    // 过滤掉不分配的IP
[H3C]dhcp server forbidden-ip 192.168.100.255 // 过滤掉不分配的IP
[H3C]dhcp server forbidden-ip 192.168.100.1 192.168.1.255   //排除一段地址

给vlan100配置dhcp
[H3C]dhcp server ip-pool 100    //创建地址池
[H3C-dhcp-pool-100]network 192.168.1.0 24 /分配的ip地址网络
[H3C-dhcp-pool-100]gateway-list 192.168.1.1 //网关
[H3C-dhcp-pool-100]dns-list 202.102.152.3  //DNS服务器
[H3C-dhcp-pool-100]expired unlimited    //租约时间
[H3C-dhcp-pool-100]q              //退出
[H3C]dhcp server forbidden-ip 192.168.1.1    // 过滤掉不分配的IP
[H3C]dhcp server forbidden-ip 192.168.1.255 // 过滤掉不分配的IP

可能涉及的:
[H3C]undo dhcp server ip-pool 001   //删除vlan设置
[H3C]display dhcp server ip-in-use all  //查看已经获取的ip地址
[H3C]display dhcp server forbidden-ip                  //查看排除的地址范围
[H3C]static-bind ip-address 192.168.100.253 mask 255.255.255.0 hardware-address ec8e-b522-f7d5  //固定机器静态绑定的IP

保存:
[H3C]save  //保存
The current configuration will be written to the device. Are you sure? [Y/N]:y
Please input the file name(*.cfg)[flash:/startup.cfg]
(To leave the existing filename unchanged, press the enter key):
flash:/startup.cfg exists, overwrite? [Y/N]:y

 

 

发表评论:

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。

Powered By Z-BlogPHP 1.5.2 Zero

鲁ICP备19064028号 13658636711 getingbin@126.com